Software Patches and Fixes for Macintosh Links

The patches listed below are just that: patches, bug fixes, and repairs for mistakes that should have been corrected before the software was ever released. These are not upgrades; they just make the existing software work as advertised.

Click here for Windows updates.

Download Photoshop CS MultiProcessor Support update Needed only if running on a computer with multiple processors.

Download Photoshop CS Camera Raw 2.2 plug-in Needed only if you import digital camera files in raw format.

Download Adobe Photoshop G5 Plugin.
This patch is needed only if you own a Macintosh with a G5 processor. You must first update to 7.01 (see below).

Various updates and service releases for Microsoft office

Download Adobe Illustrator 10 to 10.0.3 update.
Does not include the Pantone libraries update (below).

Download Illustrator 10 to 10.0.3 Pantone update.
This corrects CMYK color values for PMS colors 7492-7547.

Download QuarkXPress 5.0 to 5.01 update.

Download Adobe Photoshop Ignore EXIF Color Space Utilities
This patch is needed only if you use ICC profiles. You must first update to 7.01 (see below).

Download Adobe Photoshop 7 to 7.01 update.

Download PageMaker 7 to 7.0.1 update

Download Illustrator 9.0 to 9.0.1 Update

Download Illustrator 9.0.1 to 9.0.2 Update
This patch requires the 9.01 update listed above to be installed first.

Download Adobe Acrobat 5 to 5.0.5 update.

Download Adobe Photoshop 6 to 6.0.1 update.

Download QuarkXPress 4.0x to 4.1 updater.

Download QuarkXPress 4.1 to 4.11 updater.

Download Adobe PageMaker 6.5 to 6.5.2 Updater.

Download Adobe Photoshop 5 to 5.0.2 Updater.

Full-blown version upgrades are not listed here. Upgrades in versions are, sad to say, generally released as money-makers for the software manufacturers. The should be approached with caution, and implemented only when the addition of features you clearly need outweigh the dangers of the bugs and errors that today's new versions inevitably contain.

Copresco generally supports older versions of software long after the manufacturer has stopped selling them. That is why the patch collection below includes updaters for older versions of many applications. If a specific bug problem is causing you to consider an upgrade, Copresco strongly recommends that you look here first for an update to your current version.

Unlike full upgrades, the patches listed here should almost always be installed. Even if you do not appear to be having trouble, these fixes are engineered to address specific problems that have been identified and usually do no harm. Even if your program appears to be running smoothly, the patch may fix a problem that will affect Copresco's ability to print your documents. A good practice is to read the release notes or "readme" file before installing, just to see how pertinent the updates are to your workflow.